My links are not working. What is wrong?

First of all, check that the link is correctly spelled, and that the correct case is used - INDEX.HTML is not the same as index.html

Next, check the file paths. A common error is to leave the location relative to another computer's filesystem, eg:- 

html">Link 

This is incorrect as it refers to a file on your PC, not on our serversFile paths should either be absolute, eg:- 

http://mysite.com/mysite.html">Link 

or relative, eg:- 

html">Link, if mysite.html is in the same directory as the page that it's linking from. 

Finally, check that there are no conflicts with other scripts on the site. Many major CMS's such as Wordpress and Joomla use URL rewriting that will interfere with the correct operation of links.
  • 0 Users Found This Useful
Was this answer helpful?

Related Articles

When I try and view my website I get an HTTP Error 403 - Forbidden message.

A '403 Forbidden' message means that the browser has requested a page that it is not...

I've put up my site but I still see the standard index page. What's up?

When we create a hosting package, we place a simple index.html page into your hosting...

I've installed the formmail script, but my form isn't working. Why?

The Formmail Script is provided via the eXtend Control Panel, full usage...

I can't see the images on my website. Why?

There are several possible reasons why your images are not showing up on your pages as...

What is LiteSpeed?

LiteSpeed Web ServerLiteSpeed Web Server is the leading high-performance, high-scalability web...

Powered by WHMCompleteSolution